Intermittent Slowness – 3E and EBH

Incident Report for eBillingHub (New)

Resolved

Message for status page: The intermittent slowness has been resolved, and service performance has returned to normal levels. We will continue to monitor the environment to ensure stability. Thank you for your patience.
Posted Feb 02, 2026 - 20:28 UTC

Identified

We’re aware of an issue causing intermittent slowness for some users. Impact may include slower response times, timeouts, or delayed processing in the application. Our teams are actively investigating and working to restore normal performance.
Posted Feb 02, 2026 - 19:18 UTC
This incident affected: APIs (Validation API).